close
Content

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input #1
3
2 4 -3
5
2 5 -1 2 -1
Sample Output #1
Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

給一個序列,找最大乘積,可以跳者選

python:

import itertools
import operator
m=0
while True:
  try:
    t=int(input())
    arr=list(map(int,input().split()))
    ans=0
    for i in range(t):#控制乘積list的頭端
      mul=1
      for j in range(i,t):#控制乘積list的尾端
        mul*=arr[j]
        ans=max(ans,mul)
    m+=1
    print(f'Case #{m}: The maximum product is {ans}.\n')
  except:
    break
arrow
arrow
    創作者介紹
    創作者 趴趴熊日常 的頭像
    趴趴熊日常

    資工趴趴熊的小天地

    趴趴熊日常 發表在 痞客邦 留言(0) 人氣()