close
Content

給你一組方程式和X求微分後的值

Looking throw the “Online Judge’s Problem Set Archive” I found a very interesting problem number 498, titled “Polly the Polynomial”. Frankly speaking, I did not solve it, but I derived from it this problem.

Everything in this problem is a derivative of something from 498. In particular, 498 was “... designed to help you remember ... basic algebra skills, make the world a better place, etc., etc.”. This problem is designed to help you remember basic derivation algebra skills, increase the speed in which world becomes a better place, etc., etc.

In 498 you had to evaluate the values of polynomial

a0x^n + a1x^n−1 + . . . + an−1x + an.

In this problem you should evaluate its derivative. Remember that derivative is defined as

a0nx^n−1 + a1(n − 1)x^n−2 + . . . + an−1.

All the input and output data will fit into integer, i.e. its absolute value will be less than 2^31.

Input

每組測資有兩行 第一行為X 第二行為方程式(降冪)

第二行最後面會先有空格在換行

Your program should accept an even number of lines of text. Each pair of lines will represent one
problem. The first line will contain one integer - a value for x. The second line will contain a list of
integers a0, a1, ..., an−1, an, which represent a set of polynomial coefficients.
Input is terminated by EOF.

Output

求出微分後的值

For each pair of lines, your program should evaluate the derivative of polynomial for the given value x
and output it in a single line.

Sample Input #1
7
1 -1 
2
1 1 1 
Sample Output #1
1
5

python:

while True:
    try:
        x = int(input()) #輸入的X值
        A = list(map(int, input().strip().split()))  #這裡放置 1X^2 + 1X^1 + 1X^0  的係數
        ans = 0
        n = len(A) - 1  #n=2
        for i in range(n):
            ans += A[i] * (n-i) * pow(x, n-1-i)  
        #第一個來說 係數 * 微分下來的次方 *新次方(要-1) 
        print(int(ans))
    except:
        break

C++
#include <iostream>
#include <sstream>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
 
int main() {
    int n;
	string s;
	int g;
	vector<int> v;
    while (cin >> n ){
		getline(cin,s);
		getline(cin,s);
		//cout<<"s "<<s<<'\n';
		stringstream ss(s);
		v.clear();
		while (ss>>g)
		{
			v.push_back(g);
		}
		
		v.pop_back();
		reverse(v.begin(),v.end());// -1 1
		long long int mul=1; 
		int ans=0;
		for (int i = 0; i < v.size(); i++)
		{

			//cout << "i: " << i << " " << v[i] << " " << ans << " " << mul << "\n";
			ans += v[i]*(i+1)*mul;
            mul *= n;
            //cout << "i: " << i << " " << v[i] << " " << ans << " " << mul << "\n";
		}
		cout<<ans<<'\n'	;
	}
    return 0;
}
/*
7
1 -1 
2
1 1 1 
*/
arrow
arrow
    創作者介紹
    創作者 趴趴熊日常 的頭像
    趴趴熊日常

    資工趴趴熊的小天地

    趴趴熊日常 發表在 痞客邦 留言(0) 人氣()